Вопрос по информатике:
Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры, находит количество элементов больших заданного числа.
- 24.10.2015 03:46
- Информатика
- remove_red_eye 19163
- thumb_up 27
Ответы и объяснения 1
#include
int main() {
int array[100]; // массив элементов
int n, k, count = 0; // вспомогательные числа
printf("Введите число для сравнения:");
scanf("%d", &k); // запоминаем число для сравнения
printf("\nВведите количество элементов:");
scanf("%d", &n); // запоминаем количество элементов в массиве
printf("\nВведите %d элементов: ", n);
for (int i = 0; i < n; i++) {
scanf("%d", &array[i]); // считываем массив
if (array[i] > k) { // если число в массиве строго (!) больше нужного
count++; // то увеличиваем счётчик
}
}
printf("\n%d элементов больше, чем %d.", count, k); // выводим результат
return 0;
}
- 26.10.2015 00:09
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.