Вопрос по информатике:
Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа четным числом
- 10.06.2018 19:08
- Информатика
- remove_red_eye 18082
- thumb_up 39
Ответы и объяснения 1
size_t sum(size_t val)
{
static size_t temp = 0;
if (val > 0) {
sum(val / 10);
temp += val % 10;
}
return temp;
}
int main()
{
(sum(123) % 2) == 0 ? cout << "True" : cout << "False";
}
- 11.06.2018 18:55
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.