Вопрос по информатике:
Дан массив a из n целых чисел. Требуется найти пять соседних элементов, сумма которых максимальна, и вывести индекс первого из указанных элементов.
Формат входных данных-
На первой строке входного файла записано натуральное число n (5≤n≤100) — число элементов в массиве.
На следующей строке через пробел записаны элементы массива aa — целые числа (|ai|≤1000).
Формат выходных данных-
Требуется вывести индекс указанного элемента, а в случае, если ответов несколько — наименьший индекс из найденных.
входные данные:
7
-1 4 6 -3 5 2 9
выходные данные:
3.
С++ , ПОМОГИТЕ!
- 25.04.2018 10:27
- Информатика
- remove_red_eye 6775
- thumb_up 19
Ответы и объяснения 1
using namespace std;
int main() {
int n, sm, im, s=0;
cin >> n;
int a[n];
for (int i=0; i> a[i];
for (int i=0; i<5; i++) s += a[i];
sm = s; im=0;
for (int i=1; i
if (s > sm) { sm = s; im = i; }
}
cout << im+1;
return 0;
}
Пример:
7
-1 4 6 -3 5 2 9
3
- 26.04.2018 21:50
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.