Вопрос по информатике:
СРОЧНО!!!!
Напишите программу, которая в последовательности целых чисел определяет значение наибольшего числа из всех нечетных введенных чисел. Программа получает на вход целые положительные числа, количество введённых чисел неизвестно. Последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность).
Количество введённых чисел не превышает 1000. Все числа не превосходят 30000. Среди введённых чисел есть хотя бы одно нечётное.
Программа должна вывести одно число: наибольшее из всех нечётных введённых чисел.
Пример работы программы:
Входные данные: 15, 20, 17, 0
Выходные данные: 17
- 01.08.2018 22:08
- Информатика
- remove_red_eye 15524
- thumb_up 39
Ответы и объяснения 1
begin
var a:=ReadSeqIntegerWhile('Введите последовательность чисел: ',x->x0);
writeln(a.Where(x->x mod 20).Max);
end.
Пример:
Введите последовательность чисел: 15 20 17 0
17
- 02.08.2018 01:18
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.