Вопрос по информатике:
PASCAL. Составить программу для решения следующей задачи: Банковский счёт с ежемесячной выплатой процентов предусматривает увеличение суммы банковского счёта на сумму, составляющую от суммы, хранящейся на счёте. При этом полученная прибавка суммы счёта суммируется с общим количеством денег на счёте и используется при расчёте прибавки на следующий месяц. Задан годовой процент 15%. определить сумму вклада y через m полных месяцев при известной начальной сумме вклада x. Значения x, m вводятся с клавиатуры. На паскале.
- 11.02.2016 07:47
- Информатика
- remove_red_eye 6297
- thumb_up 9
Ответы и объяснения 2
Var y, x, m, P: real;
Begin
P := 15;
WriteLn('Введите ваш изначальный вклад и кол-во месяцев,через которое хотите узнать сумму вклада.');
ReadLn(x, m);
if m = 12 then
Begin
y := x + (x * p / 100);
WriteLn('Ваш вклад за год:', y);
End;
if m < 12 then
Begin
y := x + (x * (p / m) / 100);
WriteLn('Ваш вклад за ', m, ' месяцев:', y:0:2);
End;
End.
- 12.02.2016 17:16
- thumb_up 17
var x: real;
i,m: integer;
begin
write('Введите сумму начального вклада: ');
readln(x);
write('Введите кол-во месяцев: ');
readln(m);
for i:=1 to m do
x := x + (x*0.15/12);
writeln('Ваш вклад за ', m, ' месяцев: ', x:0:2)
end.
- 13.02.2016 12:48
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.