Вопрос по информатике:
PascalABC.net help please Если можно то сделайте по простому
После ярмарки прошло много месяцев, городок разрастался и прибыли от торговли кроликами уже стало не хватать. Вы поняли, что скоро для города начнется эра торговли, и чтобы быть готовым к ней, вы пошли получать дополнительное математическое образование. Теперь вам предстоит решить задачу итогового экзамена.
Задача состоит в следующем: Вводится число Х, вы должны найти все делители данного числа и выписать их в строку через пробел.
Формат входных данных
Вводится целое число Х (1 <= X <= 1000000)
Формат выходных данных
Выводится строка с числами, являющимися делителями Х
Примеры
входные данные
6
выходные данные
1 2 3 6
- 07.04.2015 00:14
- Информатика
- remove_red_eye 3933
- thumb_up 17
Ответы и объяснения 1
begin
var x:=ReadInteger;
Range(1,x+1,1).ForEach(y->if x mod y=0 then write(y,' '));
end.
Пример:
20
- 07.04.2015 16:44
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.