Вопрос по информатике:
Написать программу , которая вычисляет среднюю температуру воздуха за всю неделю. Выясните, сколько раз в неделю температура была выше нуля.
- 05.06.2016 03:02
- Информатика
- remove_red_eye 9886
- thumb_up 49
Ответы и объяснения 1
Var d, k, T: integer; f: byte; a: array [1..7] of integer;
Begin f := 0;k := 0;
Writeln('Введите температуру');
for d := 1 to 7 do Begin
Write(d, ' день: ');
Readln(a[d]);
end;
for d := 1 to 7 do if a[d] > 0 then
Begin
k := k + 1;
f := 1;
end;
if f = 0 then Writeln('Всю неделю температура была ниже нуля.')
else
Writeln('Дни с температурой выше нуля - ', k);
T := a[1] + a[2] + a[3] + a[4] + a[5] + a[6] + a[7];
WriteLn('Средняя температура за неделю:', T / 7:0:2);
end.
- 06.06.2016 09:01
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.