Вопрос по информатике:
Написать программу которая в одномерном массиве , заданным вводом данных с клавиатуры заменяет все числа в массиве заданым числом. Программу в Паскаль очень срочно!!!
- 13.09.2016 07:39
- Информатика
- remove_red_eye 11548
- thumb_up 45
Ответы и объяснения 1
const
handsfree = false;
nmax = 100;
random_min = -50;
random_max = 50;
var
a: array[1..nmax] of real;
i, n, j: integer;
temp: real;
begin
{ввод массива}
if handsfree then
n := random(nmax - 5) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(random_max - random_min) + random_min;
write(a[i], ' ');
end
else
readln(a[i]);
end;
writeln();
{изменение элементов}
writeln('Число для замены =');
read(temp);
writeln('Новые значения:');
for i := 1 to n do
begin
a[i] := temp;
write(a[i], ' ');
end;
end.
- 15.09.2016 00:59
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.