Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6 и оканчивающееся на 8.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: сумму чисел, кратных 6 и оканчивающихся на 8.
- 27.01.2018 20:11
- Информатика
- remove_red_eye 18388
- thumb_up 36
Ответы и объяснения 1
i, n, s, x: integer;
begin
readln(n);
s := 0;
for i := 1 to n do
begin
readln(x);
if (x mod 10 = 8) and (x mod 6 = 0) then
s := s + x;
end;
writeln('S = ', s);
end.
- 28.01.2018 07:42
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.