Вопрос по информатике:
Срочно!!! Помогите!!!!!!
Составьте программу, для подсчета дней, месяцев с температурой 15градусов, массив в программе сформировать с помощью клавиатуры.
Pasckal ABC.
- 27.04.2018 18:35
- Информатика
- remove_red_eye 8096
- thumb_up 40
Ответы и объяснения 1
const
handsfree = false;
nmax = 31;
random_min = -20;
random_max = 30;
var
a: array[1..nmax] of real;
i, n, j: integer;
k: integer;
begin
{ввод массива}
if handsfree then
n := random(nmax - 5) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(random_max - random_min) + random_min;
write(a[i], ' ');
end
else
readln(a[i]);
end;
writeln();
{подсчет элементов}
k := 0;
for i := 1 to n do
if a[i] = 15 then
k := k + 1;
writeln('quantity = ', k);
end.
- 28.04.2018 03:15
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.