Вопрос по информатике:
Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2+.....+1/3^n на языке C++, используя цикл for
- 13.02.2017 13:40
- Информатика
- remove_red_eye 6469
- thumb_up 7
Ответы и объяснения 2
#include
using namespace std;
double find(int n) {
double rez = 1.;
for (int i = 1; i <= n; i++) {
rez += 1 / pow(3, i);
}
return rez;
}
int main() {
int n; cin >> n;
cout << find(n) << endl;
system("pause");//если не компилируется, поменяй эту строку //на getchar()
return 0;
}
- 15.02.2017 00:37
- thumb_up 26
#include
using namespace std;
typedef unsigned u;
int main()
{
u N = 3;
double s = 1.0;
for (u i = 1; i <= N; ++i) {
s += 1.0 / pow(3.0, i);
}
cout << s;
}
- 15.02.2017 05:14
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.