Вопрос по информатике:
Пользователь вводит четыре числа. Найдите наибольшее четное число среди них. Если оно не существует, выведите фразу "not found" с++
- 13.09.2018 23:17
- Информатика
- remove_red_eye 5976
- thumb_up 17
Ответы и объяснения 1
using namespace std;
typedef unsigned u;
int main()
{
int a[4], max = 0;
for (u i = 0; i < 4; ++i) {
cin >> a[i];
if(max < a[i] && a[i] % 2 == 0) max = a[i];
}
if (!max) cout << "Not found";
else cout << max;
}
- 14.09.2018 23:23
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.