Вопрос по информатике:
Дана последовательность из N случайных чисел в интервале [-50;50] . Определить количество нечетных чисел имеющих четный порядковый номер.
Напишите программу через паскаль.
- 14.04.2018 23:37
- Информатика
- remove_red_eye 15111
- thumb_up 29
Ответы и объяснения 1
var a:array[1..n] of integer;
k,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(101)-50;
write(a[i],' ');
end;
writeln;
k:=0;
for i:=1 to n do
if (a[i] mod 20)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.
Пример:
-28 -27 -46 -20 -6 -15 44 -41 2 -50
k = 3
- 15.04.2018 08:47
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.