Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно,последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300.
- 20.03.2015 07:08
- Информатика
- remove_red_eye 8893
- thumb_up 13
Ответы и объяснения 1
var
n,s,k: integer;
begin
s:=0;
k:=0;
repeat
readln(n);
if (n0) and (n mod 8 = 0) then
begin
s:=s+n;
inc(k);
end;
until n=0;
if (s0) then
writeln(s/k:0:1)
else writeln('NO');
end.
- 21.03.2015 01:20
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.