Вопрос по информатике:
Помогите пожалуйста по информатике составить программу в паскале.Создать одномерный массив А из 10 целых чисел (с помощью рандома в диапазоне (-50;100). Посчитать количество отрицательных и неотрицательных элементов массива.
- 17.08.2016 02:30
- Информатика
- remove_red_eye 13700
- thumb_up 15
Ответы и объяснения 1
begin
var a:=ArrRandom(10,-50,100); a.Println;
var k:=a.Where(x->x<0).Count;
writeln('Количество отрицательных = ',k,
', количество неотрицательных = ',10-k);
end.
Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7
- 18.08.2016 13:03
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.