Вопрос по информатике:
Помогите написать программу на языке с.
x+t при x^2+ sint> 0,1
y={ 2x+t^2 при x^2+ sint< 0,1
x-t при x^2+ sint= 0,1
- 08.10.2017 00:26
- Информатика
- remove_red_eye 7331
- thumb_up 12
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int x = 0;
int t = 0;
int y = 0;
cin >> x >> t;
if (pow(x, 2) + sin(t) > 0.1) {
y = x + t;
} else if (pow(x, 2) + sin(t) < 0.1) {
y = 2 * x + pow(t, 2);
} else if (pow(x, 2) + sin(t) == 0.1) {
y = x - t;
}
cout << y;
return 0;
}
- 09.10.2017 08:29
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.