Вопрос по информатике:
Дан двумерный массив. Определить, есть ли среди элементов массива данное число q.
Помогите написать программу, пожалуйста. Заранее спасибо :)
- 11.12.2016 08:56
- Информатика
- remove_red_eye 5586
- thumb_up 33
Ответы и объяснения 1
const n=7;
begin
Writeln('Исходный массив:');
var a:=MatrRandom(n,n,-10,10); a.Println(6);
var q:=ReadInteger('q = ');
var m:=a.ElementsByRow.Where(x->x=q).Count;
if m>0 then writeln('YES') else writeln('NO');
end.
Пример:
Исходный массив:
0 -1 -10 7 5 5 5
-3 8 8 -8 4 10 0
-2 9 -1 -4 -10 -2 2
-9 6 10 -4 3 -5 4
-3 9 4 -6 8 10 -2
4 -1 -2 8 9 -8 -3
5 6 2 5 9 3 8
q = 9
YES
- 12.12.2016 14:51
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.