Вопрос по информатике:
( НА ЯЗЫКЕ С++ ) Дан номер года (положительное целое число). Определить количество дней в
этом году, учитывая, что обычный год насчитывает 365 дней, а високосный — 366
дней. Високосным считается год, делящийся на 4, за исключением тех годов,
которые делятся на 100 и не делятся на 400 (например, годы 300, 1300 и 1900 не
являются високосными, а 1200 и 2000 — являются).
ПРИМЕР
Входные данные
1) 2000
2) 1999
Выходные данные
1) YES
2) NO
- 20.06.2018 04:05
- Информатика
- remove_red_eye 7789
- thumb_up 38
Ответы и объяснения 1
using namespace std;
int main(){
int year;
cin>>year;
if(year%4==0 && year%100!=0 && year%400==0)cout<<"Высокосный год\n";
else cout<<"Не высокосный год\n";
return 0;
}
- 21.06.2018 00:29
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.