Вопрос по информатике:
С++
Напишите программу, которая выводит на экран все цифры числа, начиная с первой.
Допустим, вводишь 123, а программа выводит 1 2 3.
- 13.02.2018 03:32
- Информатика
- remove_red_eye 7955
- thumb_up 43
Ответы и объяснения 2
#include
void digits(const unsigned &val)
{
if (val) {
std::cout << (digits(val / 10), val % 10) << " ";
}
}
int main()
{
digits(123);
return 0;
}
- 14.02.2018 05:12
- thumb_up 43
#include
using namespace std;
void digits(int *num);
int main()
{
int num;
cin >> num;
void(*ptr)(int *num);
ptr = digits;
(*ptr)(&num);
return 0;
}
void digits(int *num)
{
stack stack;
while(*num>0)
{
stack.push(*num % 10);
*num /= 10;
}
while(!stack.empty())
{
cout << stack.top() << " ";
stack.pop();
}
}
- 15.02.2018 23:08
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.