Вопрос по информатике:
Люди,помогите написать программу в Паскале. Нужно,чтобы сравнивалась дробная и целая часть вещественного числа,если она одна и та же,то тру,если нет,то false. Допустим 12.12 будет тру,а если нет,то фолс. Проблема в том,что через fruc и int сравнивается 12 и 0.12. Домножать на 100 нельзя,тк это универсальная программа,может быть и число 123.123
- 24.01.2018 11:27
- Информатика
- remove_red_eye 9907
- thumb_up 39
Ответы и объяснения 2
V: real;
c,b: integer;
begin
writeln('Введите число');
readln(V);
c:=round(V);
V:=V-c;
b:=c;
while c>0 do begin
c:=c div 10;
V:=V*10;
end;
c:=round(V);
V:=V-c;
if round(V*10000)0 then
writeln('части не равны')
else begin
if b=c then
writeln('части равны')
else
writeln('части не равны');
end;
end.
- 25.01.2018 11:07
- thumb_up 41
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadReal('Введите число:').ToString.ToWords('.');
if a.Length=2 then Writeln(a[0]=a[1])
else Writeln(False);
end.
Примеры
Введите число: 121.121
True
Введите число: 12.11999
False
- 26.01.2018 23:49
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.