Вопрос по информатике:
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная.
Формат ввода
В входном файле находится одно четырехзначное число.
Формат вывода
В выходной файл следует вывести сообщение "YES", если сумма цифр число четная или "NO", если сумма не четная.
- 24.08.2017 15:46
- Информатика
- remove_red_eye 15663
- thumb_up 47
Ответы и объяснения 1
a:array[1..4] of integer;
s,i:integer;
begin
while i < 4 do begin
i+=1;
read(a[i]);
s+=a[i];
end;
if frac(s/2) = 0 then write('yes')
else write('not');
end.
- 25.08.2017 15:52
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.