Вопрос по информатике:
В одномерном массиве вычислить долю четных положительных элементов массива. Написать программу на С#.
- 22.02.2015 03:04
- Информатика
- remove_red_eye 3597
- thumb_up 19
Ответы и объяснения 1
{
int count = 0;
Console.Write("Введите размерность массива: ");
int n = Convert.ToInt32(Console.ReadLine());
int[] mas = new int[n];
Console.WriteLine("Заполните массив: ");
for (int i = 0; i < n; i++)
{
Console.Write("\t{0} элемент массива: ", i + 1);
mas[i] = Convert.ToInt32(Console.ReadLine());
}
for (int i = 0; i < n; i++)
if (mas[i] > 0 && mas[i] % 2 == 0)
count++;
Console.WriteLine("Из {0} элементов массива {1} элементов являются положительными четными",n,count);
Console.WriteLine("{0}% элементов являются положительными четными", (double)count/n*100);
Console.ReadLine();
}
- 23.02.2015 08:31
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.