Вопрос по информатике:
Составить программу, проверяющую есть ли цифра n в числе , введённом с клавиатуры. Pascal abc.
(не копируйте с других источников, неправильно)
- 19.06.2018 00:32
- Информатика
- remove_red_eye 9505
- thumb_up 27
Ответы и объяснения 1
var a,n: integer;
f: byte;
begin
f:=0;
readln(a,n);
while a0 do
begin
if a mod 10=n then f:=1;
a:=a div 10;
end;
if f=1 then write('цифра ',n,' присутствует в числе')
else write('в числе нет цифры ',n);
end.
- 19.06.2018 13:14
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.