Вопрос по информатике:
Введите размер массива N и заполните массив из N элементов числа Фибоначчи равны 1, а каждое следующее число равно сумме двух предыдущих.
Помогите пожалуйста составить программу..
- 02.06.2018 19:14
- Информатика
- remove_red_eye 15595
- thumb_up 39
Ответы и объяснения 1
a:array of integer;
begin
write('n = ');
readln(n);
SetLength(a,n);
a[0]:=1; a[1]:=1;
for var i:=2 to n-1 do a[i]:=a[i-2]+a[i-1];
for var i:=0 to n-1 do write(a[i],' ');
writeln;
end.
Пример:
n = 10
1 1 2 3 5 8 13 21 34 55
- 03.06.2018 09:19
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.