Вопрос по информатике:
Родители разрешили мальчику Косте выбрать себе игрушку. Костя идет вдоль полки, на которой стоят наборы солдатиков. При том в первом наборе Xсолдатиков, во втором X+1, в третьем X+2 и так далее. Каждый раз, видя более крупный набор, Костя восклицает: "I want this set with X soldiers!". Напишите программу, выводящую восклицания Кости на отдельных строках, если известно, что в последнем наборе на полке Z солдатиков.
C++ в цикле for
Пж очень надо
- 24.08.2017 02:16
- Информатика
- remove_red_eye 3811
- thumb_up 32
Ответы и объяснения 2
using namespace std;
int main()
{
int x, z;
cout <> x, cout << "\n";
cout <> z, cout << "\n";
for (int i=x; i<=z; i++) {
cout << "I want this set with " << i << " soldiers!\n";
}
return 0;
}
Пример:
x = 5
z = 10
I want this set with 5 soldiers!
I want this set with 6 soldiers!
I want this set with 7 soldiers!
I want this set with 8 soldiers!
I want this set with 9 soldiers!
I want this set with 10 soldiers!
- 25.08.2017 08:58
- thumb_up 31
#include
#include
int main(){
setlocale(0,"russian");//установка русского языка
int x,z;
do{
printf("Введите количество солдатиков в первом наборе(x): ");
scanf("%d",&x);
if(x<0)
printf("Количество солдатиков - число положительное.\n");
}while(x < 0);
do{
printf("Введите количество солдатиков в последнем наборе (z): ");
scanf("%d",&z);
if(z < x)
printf("В последнем наборе солдатиков должно быть не менее чем в первом.\n");
}while(z < x);
printf("Проходя мимо полок с игрушками Костя восклицает:\n");
for(; x < z; x++)
printf("\tI want this set with %dsoldiers\n",x+1);
system("pause");
return 0;
}
- 27.08.2017 00:21
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.