Вопрос по информатике:
СРОЧНО!!! ПОМОГИТЕ!
Составить алгоритм вычисления выражения S=sinx+sin^2x+...+sin^nx. Повторяющимся действием будет S=Ssinx, начальное значение суммы S=sinx.
- 23.11.2017 18:51
- Информатика
- remove_red_eye 14597
- thumb_up 31
Ответы и объяснения 1
begin
readln(x,n);
s:=0;
sn:=1;
for i:=1 to n do
begin
sn:=sn*sin(x);
s:=s+sn;
end;
writeln('s = ',s:6:4);
end.
Пример:
0.9 5
s = 2.5490
- 24.11.2017 12:59
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.