Вопрос по информатике:
Помогите пожалуйста написать эту программу с while!
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — количество чисел, кратных 3.
- 13.11.2017 06:53
- Информатика
- remove_red_eye 8219
- thumb_up 32
Ответы и объяснения 1
begin
write('n = '); readln(n);
k:=0; p:=0;
while k
read(m);
if m mod 3 = 0 then p:=p+1;
k:=k+1;
end;
writeln('количество чисел, кратных 3: ',p);
end.
n = 6
10 -13 14 -15 21 23
количество чисел, кратных 3: 2
- 14.11.2017 03:12
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.