Вопрос по информатике:
Pascal. Составить программу которая позволяет вывести трех значное число, если первая цифра числа четное,то поменять местами последнию и среднию,иначе поменять первую и среднию. За эту задачу дам 15 баллов.
- 25.08.2016 14:59
- Информатика
- remove_red_eye 11708
- thumb_up 14
Ответы и объяснения 1
b,c:real;
begin
readln(S); // вводим трёхзначное число
a:= (S div 100) mod 2; // получаем 1 цифру
if a = 0 then begin // проверяем
b:= S div 10;
b:= b - S div 100 * 10 ; // "вытаскиваем" среднюю цифру
c:= S mod 10; // берём последнюю writeln(S div 100,c,b);
end
else begin
b:= S div 10;
b:= b - S div 100 * 10 ; // повторяем со средней цифрой
c:= S mod 10; // берём последнюю (также повторяем)
writeln(b,S div 100,c);
end;
end.
Наверно можно было и попроще)))))
- 26.08.2016 19:22
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.