Вопрос по информатике:
Напишите программу, которую вводит два вещественных числа, x и y, и вычисляет значение
- 26.01.2017 20:57
- Информатика
- remove_red_eye 14890
- thumb_up 47
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (x,y):=ReadReal2('Введите x и y через пробел:');
Writeln(x**y)
end.
Примеры
Введите x и y через пробел: 2 20
1048576
Введите x и y через пробел: -2 20
1048576
Введите x и y через пробел: -2 19
-524288
Введите x и y через пробел: -0.7 19
-0.00113988951853731
Введите x и y через пробел: 3 -5
0.00411522633744856
Введите x и y через пробел: -3.5 -2.4
NaN
В последнем примере NaN - "Not a Number" (не число).
- 27.01.2017 19:54
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.