Вопрос по информатике:
Помогите с Паскалем. Нужно написать программу, которая с помощью функции, выводит наибольшую цифру в введенном числе.
- 22.06.2018 15:55
- Информатика
- remove_red_eye 15329
- thumb_up 50
Ответы и объяснения 2
function max(n:integer):integer;
var m:integer;
begin
n:=abs(n);
m:=0;
while n0 do
begin
if n mod 10 > m then m:=n mod 10;
n:=n div 10;
end;
max:=m;
end;
begin
write('a = ');
readln(a);
writeln('Максимальная цифра = ',max(a));
end.
Пример:
a = -185
Максимальная цифра = 8
- 23.06.2018 23:16
- thumb_up 36
// Внимание! Если программа не работает, обновите версию!
function MaxDigit(n:int64):integer;
begin
Result:=0;
n:=Abs(n);
while n>0 do (Result,n):=(Max(Result,n mod 10),n div 10)
end;
begin
var n:int64;
Write('Введите число: '); Read(n);
Writeln('Максимальная цифра равна ',MaxDigit(n))
end.
Пример
Введите число: 340458239345
Максимальная цифра равна 9
- 24.06.2018 09:06
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.