Вопрос по информатике:
Составить программу в паскале, которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента.
Требования : n - не более 10; способ заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс
ПОМОГИТЕ ПОЖАЛУЙСТА
- 11.11.2017 19:47
- Информатика
- remove_red_eye 18755
- thumb_up 47
Ответы и объяснения 1
var a : array of longInt; i, n, max : integer;
begin write('Введите размер массива'); read(n); writeln; setLength(A,n); writeln('Введите элементы массива'); for i := 0 to n - 1 do read(a[i]); writeln('Исходный массив:'); for i := 0 to n - 1 do write(a[i], ' '); writeln; write('Максимальный элемент: '); max := MaxIntValue(a); writeln(max); writeln('Изменённый массив:'); for i := 0 to n - 1 do begin a[i] += max; write(a[i], ' '); end; writeln;end.
- 12.11.2017 18:53
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.