Вопрос по информатике:
Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента.
Требования : n - не более 10; способ заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс
- 21.05.2015 04:19
- Информатика
- remove_red_eye 8831
- thumb_up 27
Ответы и объяснения 1
var n, max: integer;
begin
read(n);
for var i := 1 to n do begin
read(a[i]);
end;
for var i := 1 to n do begin
if a[i+1] > a[i] then
max := a[i+1];
write(a[i] + ' ');
if i = n then writeln;
end;
writeln(max);
for var i := 1 to n do begin
a[i] += max;
write(a[i] + ' ');
end;
end.
- 22.05.2015 05:39
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.