Вопрос по информатике:
Помогите пожалуйста решить эти задачи языком Паскаля:
1. Составить программу для вычисления длины окружности, если радиус R = 5,7,9, ...., 21 см
2. С клавиатуры вводится n действительных чисел. Найти количество положительных и количество отрицательных чисел
- 16.03.2018 21:34
- Информатика
- remove_red_eye 17310
- thumb_up 44
Ответы и объяснения 1
var s: integer;
a: array [1..9] of integer;\
i: byte;
begin
a[1] := 5;
for i := 1 to 9 do
a[i] := a[1] + 2 * i;
for i := 1 to 9 do
begin
s := 3 * (a[i] * a[i]);
writeln(s);
end;
end.
2)
program ez_2;var
s, m, b: integer;
a: array [1..9] of integer;
i: byte;
begin
readln(s);
for i := 1 to s do
begin
read(a[i]);
if a[i] < 0 then m := m + 1
else b := b + 1;
end;
writeln(b, ' Положительных чисел');
writeln(m, ' Отрицательных чисел');
end.
Вроде так. Если что-то не так. Пиши.
- 17.03.2018 03:20
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.