Вопрос по информатике:
Напишите программу треугольник со сторонами, пожалуйста очень надо.
Даны длины 3-х отрезков. Нужно сказать, можно ли, соединяя отрезки концами,
получить равносторонний, равнобедренный или разносторонний треугольники. Или
неравенство треугольника нарушено и его составить нельзя?
Input
Со стандартного устройства ввода вводятся через пробел 3 целых положительных числа,
не превосходящих 10000 – длины отрезков.
Output
Нужно выдать на стандартное устройство вывода одно из следующих сообщений:
“Triangle is equilateral” – если треугольник равносторонний,
“Triangle is isosceles” – если треугольник равнобедренный,
“Triangle is scalene” – если треугольник разносторонний,
“Triangle is invalid” – если треугольника не существует.
Кавычки выводить не нужно
- 02.08.2018 05:00
- Информатика
- remove_red_eye 12715
- thumb_up 25
Ответы и объяснения 1
var a,b,c:real;
begin
Read (a,b,c);
if (a+b>c)and(a+c>b)and(b+c>a)
then
if (a=b)and(b=c)and(a=c)
then write ('Triangle is scalene')
else
if (a=b)or(b=c)or(a=c)
then write ('Triangle is isosceles')
else write ('Triangle is equilateral')
else write('Triangle is invalid');
end.
- 03.08.2018 23:24
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.