Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА
ДАЮ 38 БАЛЛОВ
СРОЧНОО
Напишите программу на языке паскаль которая находит сумму первых 50 членов геометр прогрессии и выводит их в строку
- 21.04.2018 00:19
- Информатика
- remove_red_eye 10993
- thumb_up 7
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (b1,q):=ReadReal2
('Введите значение первого члена и знаменателя прогрессии:');
Writeln('Сумма первых 50 членов прогрессии равна ',
b1*(1-q**50)/(1-q));
Write('Члены прогрессии: '); SeqGen(50,i->b1*q**i).Println;
end.
Пример
Введите значение первого члена и знаменателя прогрессии: 1.2 2.3
Сумма первых 50 членов прогрессии равна 1.12623675002648E+18
Члены прогрессии: 1.2 2.76 6.348 14.6004 33.58092 77.236116 177.6430668 408.57905364 939.731823371999 2161.3831937556 4971.18134563788 11433.7170949671 26297.5493184244 60484.363432376 139114.035894465 319962.282557269 735913.249881719 1692600.47472795 3892981.09187429 8953856.51131087 20593869.976015 47365900.9448345 108941572.173119 250565615.998174 576300916.795801 1325492108.63034 3048631849.84979 7011853254.65451 16127262485.7054 37092703717.1224 85313218549.3814 196220402663.577 451306926126.227 1038005930090.32 2387413639207.74 5491051370177.81 12629418151409 29047661748240.6 66809622020953.4 153662130648193 353422900490843 812872671128940 1.86960714359656E+15 4.30009643027209E+15 9.8902217896258E+15 2.27475101161393E+16 5.23192732671205E+16 1.20334328514377E+17 2.76768955583067E+17 6.36568597841055E+17
- 22.04.2018 10:54
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.