Вопрос по информатике:
Помогите решить задачи на составление программы линейной структуры с переменной:
1. Заработок рабочих на фабрике составил 624750 руб. Его нужно разделить поровну между а рабочих и k служащих. Выведите заработок каждого работника.
2. Мальчик может бегать в 3 раза быстрее, чем ходить. Скорость его ходьбы равна y км/ч. Он принял участие в марафонском забеге, но сошел с дистанции, пробежав только x км. Сколько времени он затратил на преодоление этого расстояния.
- 16.03.2018 00:27
- Информатика
- remove_red_eye 2974
- thumb_up 44
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
Writeln('Заработок работника равен ',624750/(a+k))
end.
Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750
№2
begin
var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
var x:=ReadReal('Мальчик пробежал, км: ');
Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.
Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км: 12
Затрачено времени на бег, ч: 0.77
- 17.03.2018 00:55
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.