Вопрос по информатике:
Даны 5 чисел (могут быть и отрицательные и положительные), вывести нечетные числа, которые меньше нуля.
Написать программу Pascal ABC
- 23.08.2017 17:02
- Информатика
- remove_red_eye 6405
- thumb_up 20
Ответы и объяснения 1
begin
readln(a,b,c,d,e);
if (a mod 20)and(a<0) then write(a);
if (b mod 20)and(b<0) then write(' ',b);
if (c mod 20)and(c<0) then write(' ',c);
if (d mod 20)and(d<0) then write(' ',d);
if (e mod 20)and(e<0) then write(' ',e);
end.
Пример:
-15 42 -10 27 -79
-15 -79
- 24.08.2017 13:02
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.