Вопрос по информатике:
Составить программу на Паскале. Вася делает задачу за а часов, в минут, с секунд. Ему необходимо выполнить n задач. Сколько времени он потратит?
ПОМОГИТЕ ПОЖАЛУЙСТА
- 02.03.2017 12:32
- Информатика
- remove_red_eye 13399
- thumb_up 32
Ответы и объяснения 2
begin
readln(a);
readln(b);
readln(c);
readln(n);
a:=a*3600;
b:=b*60;
c:=(c+a+b)*n;
a:=c div 3600;
b:=(c div 60)-(a*60);
c:=c-(b*60)-(a*3600);
writeln('Часы: ',a,' Минуты: ',b,' Секунды: ',c);
end.
- 03.03.2017 03:21
- thumb_up 21
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('Сколько часов, минут и секунд надо на задачу?');
var n:=ReadInteger('Сколько задач?');
var t:=n*(c+60*b+3600*a);
Write('Будет затрачено ',t div 3600,' час ');
t:=t mod 3600;
Write(t div 60,' мин ',t mod 60,' c')
end.
Пример
Сколько часов, минут и секунд надо на задачу? 1 13 42
Сколько задач? 6
Будет затрачено 7 час 22 мин 12 c
- 04.03.2017 06:16
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.