Вопрос по информатике:
Написать программу (с program. var и тд)
Дано семизначное число. Найти сумму,произведение и среднее арифметическое этих цифр
- 19.09.2017 21:23
- Информатика
- remove_red_eye 18159
- thumb_up 30
Ответы и объяснения 2
begin
readln(a);
s:=0; p:=1;
for i:=1 to 7 do
begin
b:=a mod 10;
s:=s+b;
p:=p*b;
a:=a div 10;
end;
writeln('s = ',s,' p = ',p,' sr = ',s/7:5:2);
end.
Пример:
1389546
s = 36 p = 25920 sr = 5.14
- 20.09.2017 06:57
- thumb_up 14
_________________________________________
Примеры:
_________________________________________
Введите семизначное число: 4564564
Среднее арифметическое цифр числа: 4.85714
Введите семизначное число: 6535684
Среднее арифметическое цифр числа: 5.29
Введите семизначное число: 6563258
Среднее арифметическое цифр числа: 5.00
- 21.09.2017 12:09
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.