Вопрос по информатике:
Первое задание
дано целое двузначное число x .выведите число , полученное при перестановке его цифр . значение x ввести с клавиатуры
второе задание
дано целое трёхзначное число x . составьте программу вычисления суммы и произвидения цифр трёхзначного числа x . значение x ввести с клавиатуры
- 05.09.2018 05:27
- Информатика
- remove_red_eye 13609
- thumb_up 26
Ответы и объяснения 1
var x,y:integer;
begin
readln(x);
y:=(abs(x) mod 10)*10+(abs(x) div 10);
if x<0 then y:=-y;
writeln(y);
end.
Пример:
-25
-52
2)
var x,x1,x2,x3:integer;
begin
readln(x);
x:=abs(x);
x1:=x div 100;
x2:=x div 10 mod 10;
x3:=x mod 10;
writeln('S = ',x1+x2+x3,' P = ',x1*x2*x3);
end.
Пример:
271
S = 10 P = 14
- 06.09.2018 15:02
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.