Вопрос по информатике:
Паскаль!!!
Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
- 05.02.2018 17:07
- Информатика
- remove_red_eye 18602
- thumb_up 49
Ответы и объяснения 1
var x: integer;
begin
write('Введите число: ');
readln(x);
writeln('последняя цифра куба: ',(sqr(x mod 10)*(x mod 10)) mod 10);
write('последняя цифра квадрата: ',(sqr(x mod 10)) mod 10);
end.
- 06.02.2018 22:22
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.