Вопрос по информатике:
Составьте программу в Паскале для поиска:
a)суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры
b) произведения отрицательных элементов массива а от 1 до 100
c) количества нулевых элементов массива с сотней элементов
- 21.05.2018 19:20
- Информатика
- remove_red_eye 13824
- thumb_up 22
Ответы и объяснения 1
const n=10;
var a:array[1..n] of integer;
i,sum:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i]:4);
if a[i]>0 then sum:=sum+a[i];
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
- 22.05.2018 08:27
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.