Вопрос по информатике:
Дано целое двузначное число x.Составьте программу вычисления суммы и произведения цифр числа х.Значение x ввести с клавиатуры
- 27.09.2017 01:40
- Информатика
- remove_red_eye 8053
- thumb_up 10
Ответы и объяснения 1
var
n, p, s, i: integer;
begin
s := 0;p := 1;
readln(n);
while n > 0 do
begin
i := n mod 10;
s := s + i;
p := p * i;
n := n div 10;
end;
writeln('Сумма: ', s, ' Произведение:', p);
end.
- 28.09.2017 14:59
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.