Вопрос по информатике:
Помогите пж, информатика
Даны 3 числа a,b,c, составить программу, определяющую, существует от треугольник со сторонами a,b,c, и если существует, то является ли он прямоугольным, тупоугольным, остроугольным
- 08.07.2015 07:29
- Информатика
- remove_red_eye 2986
- thumb_up 26
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadReal3('Введите стороны треугольника:');
if (a+b>c) and (a+c>b) and (b+c>a) then begin
var alpha:=ArcCos((b*b+c*c-a*a)/(2*b*c));
var beta:=ArcCos((a*a+c*c-b*b)/(2*a*c));
var gamma:=Pi-alpha-beta;
var max:=Max(Max(alpha,beta),gamma);
var d:=max-Pi/2;
if abs(d)<=1e-12 then Writeln('Треугольник прямоугольный')
else if d<0 then Writeln('Треугольник остроугольный')
else Writeln('Треугольник тупоугольный')
end
else Writeln('Треугольник не существует')
end.
Примеры
Введите стороны треугольника: 3.54 5.18 8.32
Треугольник тупоугольный
Введите стороны треугольника: 30 40 50
Треугольник прямоугольный
- 09.07.2015 09:23
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.