Вопрос по информатике:
Помогите с информатикой,пожалуйста
Написать программу в Паскале,которая по координатам 2х введенных точек определяла бы четверть координатной плоскости,где они находятся(можно сделать через 4 if),а также длину отрезка между ними(используя функцию SQRT и формулу длины отрезка)
- 05.11.2015 00:11
- Информатика
- remove_red_eye 11849
- thumb_up 43
Ответы и объяснения 1
var
x,y: real;begin
clrscr;
write ('x = '); read (x);
write ('y = '); readln (y); if (x > 0) and (y > 0) then
writeln ('Номер четверти координатной плоскости:I')
else
if (x 0) then
writeln ('Номер четверти координатной плоскости:II')
else
if (x < 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:III')
else
if (x > 0) and (y < 0) then
writeln ('Номер четверти координатной плоскости:IV')
else
if (x>0)or(x<0) and (y=0) then writeln ('-. Точка лежит на оси. X')
else
if (y>0)or(y<0) and (x=0) then writeln ('-. Точка лежит на оси. Y')
else writeln ('-. Точка лежит в центре.');readln
end.
- 05.11.2015 14:17
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.