Вопрос по информатике:
Воробей Джек прыгает по изгороди с колышка на соседний колышек. Каждый прыжок занимает у него 1 секунду. Он делает A прыжков вперед, потом B прыжков назад (B Формат ввода:
N A B
Пример ввода:
11 4 1
Формат вывода:
k – минимальное количество секунд
Пример вывода:
14
pascal
- 08.07.2018 00:08
- Информатика
- remove_red_eye 13389
- thumb_up 22
Ответы и объяснения 1
ans,n, a, b,i,j:integer;
begin
Readln(n, a, b);
i:= 1;ans:=0;
while true do begin
for j:= 1 to a do
if i + j > n then break
else ans:= ans + 1;
i:= i + a;
if i >= n then break;
i:= i - b;
ans:= ans + b;
end;
Writeln(ans);
end.
- 08.07.2018 13:06
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.