Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет
сумму всех чисел, кратных 7 и оканчивающихся на 1. Программа получает на вход нату-
ральные числа, количество введённых чисел неизвестно, последовательность чисел за-
канчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300. Программа
должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 1.
- 26.09.2017 05:20
- Информатика
- remove_red_eye 2694
- thumb_up 19
Ответы и объяснения 2
begin
s:=0; n:=0;
repeat
if ((n mod 7)=0) and ((n mod 10)=1) then s:=s+n;
read(n);
until n=0;
writeln('сумма: ',s);
end.
14 21 35 27 91 16 0
сумма: 112
- 27.09.2017 02:01
- thumb_up 1
//Версия 3.3, сборка 1611
begin
write(ReadSeqIntegerWhile(x->x0).Where(x->(x mod 10=1) and (x mod 7=0)).Sum());
end.
- 28.09.2017 23:33
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.