Вопрос по информатике:
Напишите программу для записи четырехзначного числа в обратном порядке.
Например:
2451-->1542
Паскаль.
- 24.01.2018 05:52
- Информатика
- remove_red_eye 782
- thumb_up 20
Ответы и объяснения 2
begin
write('n = '); readln(n);
m:=0;
repeat
m:=m*10+(n mod 10);
n:=n div 10;
until n=0;
writeln(m);
end.
n = 2456
6542
- 25.01.2018 14:20
- thumb_up 5
//Версия 3.3, сборка 1611
begin
ReadInteger().ToString().Reverse().Select(x->x.ToDigit()).Println('');
end.
- 26.01.2018 17:47
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.