Вопрос по информатике:
99 баллов!! Паскаль! Срочно!
Напишите программу вычисления выражения: s = x^3 + x^5 + x^n, где x и n вводятся с клавиатуры. Используйте функцию вычисления степени.
- 21.12.2016 00:29
- Информатика
- remove_red_eye 18178
- thumb_up 31
Ответы и объяснения 1
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var x:=ReadReal('x=');
var s:=x**3+x**5+x**n;
Writeln(s)
end.
2. Со стандартной функцией возведения в степень
begin
var n:=ReadInteger('n=');
var x:=ReadReal('x=');
var s:=Power(x,3)+Power(x,5)+Power(x,n);
Writeln(s)
end.
Пример
n= 8
x= 2.3523
1022.47383513855
3. С собственной лямбда-функцией возведения в степень
begin
var n:=ReadInteger('n=');
var x:=ReadReal('x=');
var Pow:(real,integer)->real:=(a,b)->Exp(b*Ln(a));
var s:=Pow(x,3)+Pow(x,5)+Pow(x,n);
Writeln(s)
end.
4. С собственной обычной функцией возведения в степень
function Pow(a:real; b:integer):=Exp(b*Ln(a));
begin
var n:=ReadInteger('n=');
var x:=ReadReal('x=');
var s:=Pow(x,3)+Pow(x,5)+Pow(x,n);
Writeln(s)
end.
5. На "древнешкольном", в стиле ТурбоПаскаль-1974 языке
function Pow(a:real; b:integer):real;
begin
Pow:=Exp(b*Ln(a))
end;
var
n:integer;
x,s:real;
begin
Write('n='); Read(n);
Write('x='); Read(x);
s:=Pow(x,3)+Pow(x,5)+Pow(x,n);
Writeln(s)
end.
- 22.12.2016 23:01
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.