Вопрос по информатике:
Составьте программу для вычисления суммы цифр заданного трехзначного числа.
На паскале
- 06.08.2018 19:09
- Информатика
- remove_red_eye 9774
- thumb_up 27
Ответы и объяснения 1
n:integer;
begin
Write('n = '); Read(n);
Writeln(n div 100+(n div 10) mod 10+n mod 10)
end.
Пояснения.
n div 100 дает первую цифру: результат деления нацело числа на 100.
(n div 10) mod 10 дает вторую цифру: вычисляется результат деления нацело числа на 10 и от него берется остаток деления на 10.
n mod 10 дает третью цифру: остаток целочисленного деления числа на 10.
- 07.08.2018 21:58
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.